Why cant I get shadow on transparent background?

#1
Why cant I get shadow on transparent background? - OK, I know this has been asked a few times, but for the life of me, no matter what I try, and following the directions it just wont work! Supposed to be something super simple right?

At any rate, here is what I got... here is super basic file attached. All I want is for the box to throw shadow on the shadowmat, so that when I render it gives me a PNG file with transparent background but with the shadow so I can further modify it in Photoshop if need be. So, I have an "area" light as light source, the shadowmat, and the camera with background set to 0%. So why is it not working?

Appreciate any help! :)
 

Attachments

frank beckmann

Well-known member
#2
Not on my Mac right now - so I have to guess: are you probably using the Falcon render engine? If so it's not compatible with the shadow-mat right now.

Cheers
Frank
 
#5
OK, I'm using an "area" light, and I get three choices there for shadow type: None, Raytrace, Raytrace+trans - I choose both of them but still showing the shadowmat when I render it
 

frank beckmann

Well-known member
#8
It's called"raytrace+trans" and it's not enabled in your screenshot.
And you probably need to adjust (decrease value) of the "white point" property in the shadowmat material.
 
#9
oh yeah, the screenshot I made when I had Raytrace selected, but I had tried it with Raytrace+trans just before too, and still the same. I attached the actual .jas file in my first post. Maybe you can check it ouw when you have a chance later on.. I know it's late
 
#12
I didnt see that being referenced at all in any of the posts before. Thank you Frank, I hadnt used Cheetah in a long time so I'm very rusty, so thank you for helping me so quickly with this, as usual you are the BEST! :)) thank you, thank you!
 
#15
Frank.. sorry, stll having a small issue - just realized that though the background itlself is transparent the shadows themselves are not. I only noticed that when I brought the PNG file into photoshop. This is the file I have so far... if you can take a look at it if you can would be great... I did try different settings but still couldnt get them to be transparent...

Thanks again!
 

Attachments

frank beckmann

Well-known member
#16
OK - 3 more things we have to take into account:
1. the core-shadow is not transparent because no light rays are reaching this area
2. to prevent this from happening add a "Radiosity tag" to the camera set to "Radiosity", "Diffuse Scatterings to 6
3. and last: You´ ve set the "White point:" to 0,0 - this means it´ s practically disabled. Set it at least to 0,01

Cheers
Frank
 

Attachments

#17
Thank you for checking the file out Frank. Unfortunately when I render and check out the file the shadows still are not transparent.
I'll keep playing around with it and see if I can get it to work, but thank you again for helping me out! :)

Have a good night!
 
Top