Flipped object not getting lights properly with motion blur on in Falcon

#1
Flipped object not getting lights properly with motion blur on in Falcon

There's something odd happening with the Falcon renderer using motion blur. I've done lots of testing and figured out it has something to do with flipping objects (scaling by -1 in x) and using a bumpmap.
I have this animated mechanical bird, with simple image texture nodes feeding the diffuse and bump directly. I thought it would be clever to animate the port (right) wing, put it in a group, duplicate the group, flip the new group and use that as the starboard (left) wing. It worked great until I started rendering with motion blur. Suddenly the flipped wing, after the first frame, was no longer getting lights. So the first frame looks fine (no mb) and subsequent frames are essentially more-or-less black. If I remove the bump map (sever the image node's connection to the bump map), it gets the lights again.
 

Attachments

#2
When you scale an object by -1, not only the geometry gets reversed but the normals also (pointing inwards now).
That can cause all kinds of problems like the motion blur glitch you discovered.
Better to use symmetry modifier or creator which leave the normal orientation intact.
 
#3
Thanks for the explanation, misoversaturated. :icon_thumbup:



When you scale an object by -1, not only the geometry gets reversed but the normals also (pointing inwards now).
That can cause all kinds of problems like the motion blur glitch you discovered.
Better to use symmetry modifier or creator which leave the normal orientation intact.
 
Top